Skip to main content
← All vulnerabilities
CVE-2023-26053

Gradle usage of long IDs for PGP keys opens potential for collision attacks

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 6.9.4, 7.6.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Gradle is a build tool with a focus on build automation and support for multi-language development. This is a collision attack on long IDs (64bits) for PGP keys. Users of dependency verification in Gradle are vulnerable if they use long IDs for PGP keys in a `trusted-key` or `pgp` element in their dependency verification metadata file. The fix is to fail dependency verification if anything but a fingerprint is used in a trust element in dependency verification metadata. The problem is fixed in Gradle 8.0 and above. The problem is also patched in Gradle 6.9.4 and 7.6.1. As a workaround, use only full fingerprint IDs for `trusted-key` or `pgp` element in the metadata is a protection against this issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • gradle gradle

    From 6.2 · fixed in 6.9.4; From 7.0.0 · fixed in 7.6.1

References 3

GitHub · gradle/gradle

security.netapp.com