Skip to main content
← All vulnerabilities
CVE-2023-25571GHSA-7HV8-3FR9-J2HV

Backstage has XSS Vulnerability in Software Catalog

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.2.0, 0.12.4, 1.7.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Backstage is an open platform for building developer portals. `@backstage/catalog-model` prior to version 1.2.0, `@backstage/core-components` prior to 0.12.4, and `@backstage/plugin-catalog-backend` prior to 1.7.2 are affected by a cross-site scripting vulnerability. This vulnerability allows a malicious actor with access to add or modify content in an instance of the Backstage software catalog to inject script URLs in the entities stored in the catalog. If users of the catalog then click on said URLs, that can lead to an XSS attack. This vulnerability has been patched in both the frontend and backend implementations. The default `Link` component from `@backstage/core-components` version 1.2.0 and greater will now reject `javascript:` URLs, and there is a global override of `window.open` to do the same. In addition, the catalog model v0.12.4 and greater as well as the catalog backend v1.7.2 and greater now has additional validation built in that prevents `javascript:` URLs in known annotations. As a workaround, the general practice of limiting access to modifying catalog content and requiring code reviews greatly help mitigate this vulnerability.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • backstage backstage

    fixed in 1.2.0; fixed in 0.12.4; fixed in 1.7.2

  • @backstage/core-componentsnpm

    fixed in 0.12.4

  • @backstage/catalog-modelnpm

    fixed in 1.2.0

  • @backstage/plugin-catalog-backendnpm

    fixed in 1.7.2

References 2

GitHub · backstage/backstage