Skip to main content
← All vulnerabilities
CVE-2023-25141GHSA-GVG3-83Q4-RFHQ

JNDI injection into Apache sling-org-apache-sling-jcr-base

Published
Last modified
published
Not listed in CISA KEV
Critical (apache)
Fix
Fixed in 3.1.12
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Apache Sling JCR Base < 3.1.12 has a critical injection vulnerability when running on old JDK versions (JDK 1.8.191 or earlier) through utility functions in RepositoryAccessor. The functions getRepository and getRepositoryFromURL allow an application to access data stored in a remote location via JDNI and RMI. Users of Apache Sling JCR Base are recommended to upgrade to Apache Sling JCR Base 3.1.12 or later, or to run on a more recent JDK.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Sling JCR Base

    From 2.0.6 · fixed in 3.1.12

  • org.apache.sling:org.apache.sling.jcr.baseMaven

    fixed in 3.1.12

References 1

sling.apache.org