Skip to main content
← All vulnerabilities
CVE-2023-23920

An untrusted search path vulnerability exists in Node.js.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 14.21.3, 16.19.1, 18.14.1, 19.6.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

An untrusted search path vulnerability exists in Node.js. <19.6.1, <18.14.1, <16.19.1, and <14.21.3 that could allow an attacker to search and potentially load ICU data when running with elevated privileges.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • NodeJS Node

    From 4.0; From 5.0; From 6.0; From 7.0; From 8.0; From 9.0; From 10.0; From 11.0; From 12.0; From 13.0; From 14.0 · fixed in 14.21.3; From 15.0; From 16.0 · fixed in 16.19.1; From 17.0; From 18.0 · fixed in 18.14.1; From 19.0 · fixed in 19.6.1

References 4

nodejs.org

lists.debian.org

security.netapp.com

debian.org