Skip to main content
← All vulnerabilities
CVE-2023-22454

Discourse vulnerable to Cross-site Scripting through pending post titles descriptions

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.8.14, 3.0.0.beta16
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Discourse is an option source discussion platform. Prior to version 2.8.14 on the `stable` branch and version 3.0.0.beta16 on the `beta` and `tests-passed` branches, pending post titles can be used for cross-site scripting attacks. Pending posts can be created by unprivileged users when a category has the "require moderator approval of all new topics" setting set. This vulnerability can lead to a full XSS on sites which have modified or disabled Discourse’s default Content Security Policy. A patch is available in versions 2.8.14 and 3.0.0.beta16.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • discourse discourse

    fixed in 2.8.14; From 2.9.0.beta0 · fixed in 3.0.0.beta16

References 2

GitHub · discourse/discourse