Skip to main content
← All vulnerabilities
CVE-2023-20873GHSA-G5H3-W546-PJ7F

In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry coul

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.0.6, 2.7.11, 2.6.15, 2.5.15
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.6+. 2.7.x users should upgrade to 2.7.11+. Users of older, unsupported versions should upgrade to 3.0.6+ or 2.7.11+.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • n/a Spring Boot

    Version range not reported

  • org.springframework.boot:spring-boot-actuator-autoconfigureMaven

    From 3.0.0 · fixed in 3.0.6

  • org.springframework.boot:spring-boot-actuator-autoconfigureMaven

    From 2.7.0 · fixed in 2.7.11

  • org.springframework.boot:spring-boot-actuator-autoconfigureMaven

    From 2.6.0 · fixed in 2.6.15

  • org.springframework.boot:spring-boot-actuator-autoconfigureMaven

    fixed in 2.5.15

References 3

spring.io

security.netapp.com