Skip to main content
← All vulnerabilities
CVE-2023-20861GHSA-564R-HJ7V-MCR5

In Spring Framework versions 6.0.0 - 6.0.6, 5.3.0 - 5.3.25, 5.2.0.RELEASE - 5.2.22.RELEASE, and older unsupported versions, it is possible f

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 6.0.7, 5.3.26, 5.2.23.RELEASE
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

In Spring Framework versions 6.0.0 - 6.0.6, 5.3.0 - 5.3.25, 5.2.0.RELEASE - 5.2.22.RELEASE, and older unsupported versions, it is possible for a user to provide a specially crafted SpEL expression that may cause a denial-of-service (DoS) condition.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • n/a Spring Framework

    Version range not reported

  • org.springframework:spring-expressionMaven

    From 6.0.0 · fixed in 6.0.7

  • org.springframework:spring-expressionMaven

    From 5.3.0 · fixed in 5.3.26

  • org.springframework:spring-expressionMaven

    fixed in 5.2.23.RELEASE

References 2

spring.io

security.netapp.com